Warp3 on AMD64 box

Warp3 on AMD64 box

Post by Krister Ha » Thu, 31 Mar 2005 03:11:21


Struggled for weeks to get Warp 452 working and with the help of this NG
I finally got it going. Thought I would just see if Warp3 FP43 would
work on the new box: (Motherboard MSI6741 with VIA K8T800 chipset and
VIA 8237 South Bridge, CPU=AMD64 3400+, 1024 MB RAM, SATA 2x200GB drives
and GeForce FX5200 video card). It did work!

Did the following:
1. Extracted a rar backup file of an Warp3 partition from the old box
to a newly formatted HPFS partition on the new box.
2. Edited (from XP using Hpfswk2.zip) the config.sys: REMMED old sound
driver, old NIC driver, APM.SYS and VAPM.SYS and MOUSE.SYS and added
AMOUSE.SYS (plus its directory).
3. Replaced TESTCFG.SYS with Daniela patched version
4. Used newest IBM basedevice drivers and of Daniela only
DANIS506.ADD. (This might be peculiar to my box possibly due to buggy
partitions, but had difficulty with other combination to get disk access.
5. Change to VGA by ALT-F1 + V
6. ALT-F1 + C to patch OS2LDR with PatchLDR.exe
7. Reboot. Voila - first time
 
 
 

Warp3 on AMD64 box

Post by Krister Ha » Thu, 31 Mar 2005 17:03:24


Proceded to install NIC and USP printer without problems, but Uniaud
gave this message from config.sys when booting: "SYS1718: The system
cannot find the file KEE specified in the DEVICE statment ..............
unable to open 32-bit driver...." so neither Uniaud32.sys nor
Unaud16.sys were loaded.

Thought that maybe this was due to an IRQ conflict, as with Warp3 don
have any updated kernel (with Warp4 I had kernel dated 2005-03-17) that
perhaps doesn support IRQ sharing. To test this I installed the audio
driver 823xAC97, which initially had given me an IRQ confilict message.
No, it installed but gave med that loud 100 dB tone, so the problem is
problably not an IRQ conflict. Now what?

 
 
 

Warp3 on AMD64 box

Post by Ruediger I » Thu, 31 Mar 2005 17:37:58

On Wed, 30 Mar 2005 08:03:24 UTC, Krister Hallergard



The KEE API was introduced with Warp4/FP13 Kernels. So
no wonder, that a driver using it will not work on Warp3.
There might, however, be a non-KEE version of UNIAUD.

--
Ruediger "Rudi" Ihle [S&T Systemtechnik GmbH, Germany]
http://www.yqcomputer.com/
Please remove all characters left of the "R" in my email address
 
 
 

Warp3 on AMD64 box

Post by Trevor Hem » Thu, 31 Mar 2005 18:27:24

On Wed, 30 Mar 2005 08:03:24 UTC in comp.os.os2.setup.misc, Krister



That means that Uniaud requires a Warp 4 (actually a 4.5x) kernel.

--
Trevor Hemsley, Brighton, UK.
Trevor-Hemsley at dsl dot pipex dot com
 
 
 

Warp3 on AMD64 box

Post by Krister Ha » Thu, 31 Mar 2005 20:41:35


Thak you Rudi. Where could I find a non-KEE version? My search so far
has only brought me back to version 1.0.4 of april 2003 which is a KEE
version.
 
 
 

Warp3 on AMD64 box

Post by Peter Brow » Thu, 31 Mar 2005 23:22:40

Hi Krister






I think, but may be wrong, that the later uniaud drivers do not use the
kee api.

Have a look here for some later versions ftp://ftp.os2.kiev.ua/uniaud/

Maybe this page will tell you which version to use for whatever sound
chip you are using http://www.yqcomputer.com/

Hope the above helps.

Pete
 
 
 

Warp3 on AMD64 box

Post by Krister Ha » Fri, 01 Apr 2005 07:01:11


Thanks, have not found anything here that works with Warp3.