Samba problem print to windows printer with domain

Samba problem print to windows printer with domain

Post by supp_linux » Sat, 20 Dec 2003 04:14:21


-------- Ingles

hello people.

I have a problem and this me have crazy... i think that have any
problem with the configuration. but i no have idea what is problem?

i have a redhat ES 2.1 with kernel 2.4.9-e.12 and samba 2.2.7. the
configuration of samba is the follow:

[global]
workgroup = tla
server string = Samba Server
printcap name = /etc/printcap
load printers = yes
printing = lprng
log file = /var/log/samba/%m.log
max log size = 0
security = domain
password server = tlant
encrypt passwords = yes
smb passwd file = /etc/samba/smbpasswd
*passwd:*all*authentication*tokens*updated*successfully*

Ahora bien el problema es el siguiente: Tengo un dominio llamado tla y
el
pdc es tlant (un servidor W2k server "lamentablemente") ahora bien hay
impresoras en algunas maquinas windows, y el detalle es que las
configuro

Great, Now the problem is the following: i have a domain called tla
and the PDC is tlant (server Windows 2K server), i have various pcs
with windows and this shared printers... i configure this printers
from linux with protocol smb (Samba), i use printools-tui for
configure this printers, i intro in the wizard the name resource
shared, ip adress, domain, user and password domain, but simply not
print. i thinked that problem are in the domain them add the linux to
the domain with the command:

smbpasswd -j tla -r tlant -Uadministrator%password

This show me " joined domain tla "


Probe print and nothing. I want verify if the problem is the samba, i
connected in a machine windows and this have a printer shared with
smbclient, execute the command print and the printer print the file..
the test is the following:

smbclient //jenniferg/jenny -Unelsonf%nelsonf
added interface ip=180.180.1.11 bcast=180.180.1.255
nmask=255.255.255.0
Got a positive name query response from 180.180.1.124 ( 180.180.1.124
)
smb: \> print /etc/hosts
putting file /etc/hosts as hosts-12260 (104.8 kb/s) (average 104.8
kb/s)
smb: \> quit

now. when i do from command line samba show me the message in the
status

lpstat -t
IF filter 'mf_wrapper' filter msg - 'closed *main::KID3'

And after for timeout the job is delete from queue jobs

the command lpq -L show me the following

Printer: hp1@tlalnx63b
Queue: no printable jobs in queue
Status: IF filter 'mf_wrapper' filter msg - 'closing *main::KID3' at
09:49:44.132
Status: IF filter 'mf_wrapper' filter msg - 'closed *main::KID3' at
09:49:44.132
Status: IF filter 'mf_wrapper' filter msg - 'tail process done
writing data
to *main::STDOUT' at 09:49:45.121
Status: IF filter 'mf_wrapper' filter msg - 'KID4 finished' at
09:49:45.121
Status: IF filter 'mf_wrapper' filter msg - 'KID3 finished' at
09:49:45.123
Status: IF filter 'mf_wrapper' filter msg - 'Main process finished'
at
09:49:45.124
Status: IF filter 'mf_wrapper' filter finished at 09:49:45.131
Status: printing finished at 09:49:45.131
Status: LP filter msg - 'cat: write error: Broken pipe' at
09:49:45.131
Status: waiting for printer filter to exit at 09:49:45.131
Status: accounting at end at 09:49:45.131
Status: finished 'cfA880tlalnx63b.tlant.com', status 'JFAIL' at
09:49:45.131
Status: subserver pid 12911 exit status 'JFAIL' at 09:49:45.132
Status: job 'cfA880tlalnx63b.tlant.com' attempt 2, trying 3 times at
09:49:45.132
Status: waiting for subserver to exit at 09:49:45.133
Status: attempt 3, sleeping 2