NTP in Multicast with a Coldfire52 71 + 礐linux

NTP in Multicast with a Coldfire52 71 + 礐linux

Post by pierre.sav » Sat, 05 May 2007 19:00:45


Hello,

like I say in the target of my message, I want a NTP server in Multicast
in my board Coldfire with linux.

The config is simple :

***********************************
server 127.127.1.0
fudge 127.127.1.0 stratum 1

broadcast 239.192.54.6 ttl 255
***********************************

But the multicast doesn't work with NTP. It's the only mode that doesn't
work in my NTP server.
I made a test of multicast with another service and it works so it is NTP
.... but I don't know why. Maybe it's the options in my Makefile :

***********************************
[...]
CONFOPTIONS= \
--disable-debugging \
--disable-HOPFSERIAL --disable-HOPFPCI --disable-BANCOMM \
--disable-GPSVME --disable-SHM --disable-all-clocks \
--disable-ACTS --disable-ARBITER --disable-ARCRON-MSF \
--disable-ATOM --disable-AS2201 --disable-CHU --disable-AUDIO-CHU \
--disable-DATUM --disable-FG --disable-HEATH --disable-HPGPS \
--disable-IRIG --disable-JJY --disable-LEITCH \
--disable-MSFEES --disable-MX4200 \
--disable-NMEA --disable-ONCORE --disable-PALISADE --disable-PST \
--disable-JUPITER --disable-PTBACTS --disable-TPRO --disable-TRAK \
--disable-CHRONOLOG --disable-DUMBCLOCK --disable-PCF \
--disable-SPECTRACOM --disable-TRUETIME --disable-ULINK \
--disable-WWV --disable-USNO --disable-parse-clocks \
--disable-COMPUTIME --disable-DCF7000 --disable-HOPF6021 \
--disable-MEINBERG --disable-RAWDCF --disable-RCC8000 \
--disable-SCHMID --disable-TRIMTAIP --disable-TRIMTSIP \
--disable-WHARTON --disable-VARITEXT --disable-kmem \
--enable-LOCAL-CLOCK \
--without-openssl-libdir --without-openssl-incdir --without-crypto \
--without-electricfence --without-sntp --$(NTPDATE)-ntpdate \
--$(NTPDC)-ntpdc --$(NTPQ)-ntpq

all: builddir
$(MAKE) -C builddir CFLAGS='$(CFLAGS)
-DCONFIG_FILE=\"/etc/config/ntp.conf\"'

romfs:
$(ROMFSINST) -e CONFIG_USER_NTPD_NTPD builddir/ntpd/ntpd /bin/ntpd
$(ROMFSINST) -e CONFIG_USER_NTPD_NTPDATE builddir/ntpdate/ntpdate
/bin/ntpdate
$(ROMFSINST) -e CONFIG_USER_NTPD_NTPDC builddir/ntpdc/ntpdc /bin/ntpdc
$(ROMFSINST) -e CONFIG_USER_NTPD_NTPQ builddir/ntpq/ntpq /bin/ntpq


builddir: makefile
rm -rf builddir
mkdir builddir
( \
cd builddir; \
CC="$(CC) $(CFLAGS)" LDFLAGS="$(LDFLAGS) " LIBS="$(LDLIBS)" \
MISSING="true" \
../configure --prefix= --host=m68k-elf \
--with-headers=$(ROOTDIR)/$(LINUXDIR)/include \
$(CONFIGURE_OPTS) $(CONFOPTIONS) \
)
[...]
***********************************

So I don't know how make !!!! Could you give me some help please ...?

Pierre


PS: sorry for my english


_______________________________________________
questions mailing list
XXXX@XXXXX.COM
https://lists.ntp.isc.org/mailman/listinfo/questions
 
 
 

NTP in Multicast with a Coldfire52 71 + 礐linux

Post by maye » Tue, 08 May 2007 04:42:20


This is the server configuration. Did you look at your syslog? Why did
you set ttl to 255? What about the client?


How do you know? Did you disable authentication on the client? The
default is authentication required for broadcast/multicast packets.


See above.


Danny
_______________________________________________
questions mailing list
XXXX@XXXXX.COM
https://lists.ntp.isc.org/mailman/listinfo/questions