Proper Operation of ntpq -np and ntpdc -c peers

Proper Operation of ntpq -np and ntpdc -c peers

Post by steven.j.k » Thu, 25 Sep 2008 03:13:23


I have a Red Hat 4.0 Linux workstation that is running an NTP ver 4 client
connecting to a ver 3 NTP server running on a Zyfer GPS receiver. When I
run ntpq -np as root I get the following response: No Association IDs found.



Also when I run ntpdc -c peers as root I get the following response: server
reports data not found.



Can anyone tell me what could be causing these error responses?



Steven J. Kelly

CCOP Systems Engineer

Office: (843) 218-4781

Cell: (843) 709-6675
 
 
 

Proper Operation of ntpq -np and ntpdc -c peers

Post by Richard B. » Fri, 26 Sep 2008 08:45:33


The responses you are getting suggest that ntpd is either not running or
is not properly configured!

 
 
 

Proper Operation of ntpq -np and ntpdc -c peers

Post by Steve Kost » Fri, 26 Sep 2008 11:41:01


Is the RedHat system actually configured to poll the Zypher?

Are there any restrict lines in the ntp.conf on the RedHat system? Have
you recently upgraded NTP? Did it work before the upgrade?

What are the actual versions of NTP? (e.g. 4.1.0, 4.2.4) You can view
them with ntpq -crv.

It would be helpful to see the output of ntpq -pcrv from both the Red
Hat machine and the Zypher. Please compress the lines a bit so that they
are ~70 chars long.

It would also be helpful to see the configuration for both systems.

--
Steve Kostecke < XXXX@XXXXX.COM >
NTP Public Services Project - http://www.yqcomputer.com/