IIS & ASP.NET 1.1 and ASP.NET 2.0 errors?

IIS & ASP.NET 1.1 and ASP.NET 2.0 errors?

Post by Rob R. Ain » Sat, 04 Feb 2006 08:11:21


Does anyone know why two separate ASP.NET web application running under the
same web server (IIS 6) would cause this error (Application Event viewer):

"It is not possible to run two different versions of ASP.NET in the same IIS
process. Please use the IIS Administration Tool to reconfigure your server
to run the application in a separate process."

Both web applications "I think" are running in a separate process (they are
listed under web sites, one is listed as Default Web Site and the other is
listed as myApp web site) under IIS -- one app needs 2.0 and the other needs
1.1.

Any info would be most helpful.

Thanks, Rob.
 
 
 

IIS & ASP.NET 1.1 and ASP.NET 2.0 errors?

Post by Juan T. Ll » Sat, 04 Feb 2006 08:35:16

Use the ASP.NET tab in the Internet Service Manager
to make sure the 2.0 and 1.1 apps are targeting the intended
version of the .Net Framework.

Also, you need to have 1.1 apps and 2.0 apps in different Application Pools.

Use the ISM to create a separate Application Pool for 1.1 apps
( or perhaps a separate one for 2.0 apps, depending on your original configuration )
and make sure that 1.1 Apps and 2.0 apps are assigned to separate Application Pools.

You can have as many Applications Pools as the number of Applications you have,
but remember that each AppPool takes up memory resources.

At the very least, lump all 1.1 apps in one AppPool,
and all 2.0 Apps in a separate AppPool.

You should have your critical Apps in their own AppPool.




Juan T. Llibre
ASP.NET MVP
ASPNETFAQ.COM : http://www.yqcomputer.com/
==================================

 
 
 

IIS & ASP.NET 1.1 and ASP.NET 2.0 errors?

Post by Rob R. Ain » Sat, 04 Feb 2006 08:55:07

How do I move my existing 2.0 app entry out of the current "DefaultAppPool"
into my now new "DefaultApp2Pool"?
 
 
 

IIS & ASP.NET 1.1 and ASP.NET 2.0 errors?

Post by Rob R. Ain » Sat, 04 Feb 2006 09:29:28

Ok found out how to get the references changed, but I still seem to have one
reference to my old AppPool that I just can't find or get rid off...I've
checked all the settings and nothing that is an ASP 2.0 is referencing the
ASP 1.1 AppPool but yet it still shows a listing? Very odd...
 
 
 

IIS & ASP.NET 1.1 and ASP.NET 2.0 errors?

Post by Juan T. Ll » Sat, 04 Feb 2006 09:49:04

Open the ISM and scroll down to your Application.
Right-click it and select "Properties" from the context menu.

You'll see the "Application Pool" dropdown.
Select the AppPool you want for your app.

Of course, you'll need to have *created* a new AppPool
for more than one option to be available.

To do that, scroll on the left to "Application Pools" and select it;
right-click "Application Pools" and select "New" and then "Application Pool"
from the context menu.




--
Juan T. Llibre
ASP.NET MVP
ASPNETFAQ.COM : http://www.yqcomputer.com/
==================================
 
 
 

IIS & ASP.NET 1.1 and ASP.NET 2.0 errors?

Post by Juan T. Ll » Sat, 04 Feb 2006 09:53:10

Check all your Applications' AppPools if you're still having problems.

Just make sure that, from within all of your Application's properties,
( ISM, select the Application and select the AppPool from the
"Application Pool" dropdown ) you have the correct AppPool assigned.



Juan T. Llibre
ASP.NET MVP
ASPNETFAQ.COM : http://www.yqcomputer.com/
==================================