Matlab R14 crashes on RedHat 9.0

Matlab R14 crashes on RedHat 9.0

Post by longlewi » Thu, 03 Feb 2005 09:48:38


Hello there,

I am seeing problems with Matlab R14 on my linux (RH9.0) box. I have
been using R13 on the same OS without much problems, and have just
installed R14.

However, I have been seeing the following problem.
1. start matlab with options "-nodisplay", "-nodesktop", or "-nojvm"
2. after matlab started, type "exit" to exit matlab.

Matlab will always give "segmentation violation" error and crashes.
This is 100% reproducable.

If I start matlab without any option, and exit matlab later, I
sometimes get "segmentation" error but not always.

I suppose to report it to mathworks, but would like to check the
community first to make sure I am not something wrong on my machine.

Thank you very much for the help.
/Long
 
 
 

Matlab R14 crashes on RedHat 9.0

Post by Ramachandr » Thu, 03 Feb 2005 10:39:15

I experience the same symptoms you describe. I sent the crash log to
Mathworks, but the automated analysis could not find anything.

-Rama

 
 
 

Matlab R14 crashes on RedHat 9.0

Post by Joshua Bak » Thu, 03 Feb 2005 13:54:49


Before launching matlab, 'export LD_ASSUME_KERNEL=2.4.1'.

--
Joshua Baker-LePain
Department of Biomedical Engineering
Duke University
 
 
 

Matlab R14 crashes on RedHat 9.0

Post by longlewi » Fri, 04 Feb 2005 02:26:59

Thank you Joshua,

It really solves the problem.

BTW, I was not clear in my original message. I actually installed
R14SP1 instead of R14. So this solution should apply to R14SP1 also.

Regards,
/Long
 
 
 

Matlab R14 crashes on RedHat 9.0

Post by longlewi » Fri, 04 Feb 2005 02:36:53

Another update:
After setting LD_ASSMUED_KERNEL, the matlab runs correctly with
"-nodesktop" "-nodisplay" and "-nojvm" options. However, I receive
the following error messages after starting matlab without options:

Uncaught error fetching image:
java.lang.NullPointerException
at
ice.pilots.html4.TableRowGroupBox.findAbsolutePosition(TableRowGroupBo
x.java:122)
at
ice.pilots.html4.TableRowBox.findAbsolutePosition(TableRowBox.java:69)

at ice.pilots.html4.CSSBox.findAbsolutePosition_int(CSSBox.java:195)
at
ice.pilots.html4.TableCellBox.findBoundingBox(TableCellBox.java:180)
at ice.pilots.html4.CSSBox.reqRepaint(CSSBox.java:305)
at ice.pilots.html4.CSSBox.transparentTilingImpl(CSSBox.java:872)
at ice.pilots.html4.CSSBox$1.imageComplete(CSSBox.java:806)
at sun.awt.image.PixelStore.replay(Unknown Source)
at sun.awt.image.PixelStore.replay(Unknown Source)
at sun.awt.image.InputStreamImageSource.updateFromStore(Unknown
Source)
at sun.awt.image.InputStreamImageSource.doFetch(Unknown Source)
at sun.awt.image.ImageFetcher.fetchloop(Unknown Source)
at sun.awt.image.ImageFetcher.run(Unknown Source)

It seems java related and I am currently not using much java stuff.
So I can live with it. Maybe someone out there has already seen
this problem before? Just curious.

Thanks,
/Long




box.
have