RISC OS 5.17 on an SA RiscPC

RISC OS 5.17 on an SA RiscPC

Post by Michae » Wed, 09 Feb 2011 07:29:29


I have a RISC OS 4.02 SA RiscPC.

It has a fresh !Boot

I have downloaded the HardDisc Utility, and soft-iomd.5.17.zip archive and decompressed it.

When I install the soft load and reboot, I get a postmortem.

I cannot read what the results are as it boots into RISC OS 4.

If I run ADFS::HardDisc4.$.!Boot.Choices.Boot.PreDesk.!!Softload in a task window I get:

Would you like to softload the new OS (y/N)?
(booting will intinue in 10 seconds)

Yes - softloading...

Softload version 1.13

Internal error: abort on data transfer at &000085F0

Postmortem requested
85e8 in function ROM_physaddr
Arg2: 0x0000bfd4 49108 -> [0x0000bff8 0x0000c010 0x0000c013 0x0000c016]
Arg1: 0x00000006 6
8c8c in function main
226fc10 in unknown procedure
8ff0 in anonymous function

I am not too surprised to see an error when run like this, but how do I get my machine to boot into RISC OS 5?

Is it possible to do this? or am I forgetting something like it doesn't like StrongARMs?

Cheers
Michael
 
 
 

RISC OS 5.17 on an SA RiscPC

Post by trev » Wed, 09 Feb 2011 22:45:57


AFAIK StrongARMs should be OK (although not yet for the Kinetic):
https://www.riscosopen.org/forum/forums/5/topics/410#posts-3892

Remember it's still a work in progress:
https://www.riscosopen.org/forum/forums/5/topics/410?page=5#posts-5345

 
 
 

RISC OS 5.17 on an SA RiscPC

Post by Michae » Thu, 10 Feb 2011 01:41:03

Having read through the forum, I saw in Page 5 about the IDE interface podule being the issue.

This is a basic machine except the one item I forgot about, the Ant NIC.

I assume (as it came from my school in 2002) that the firmware on the NIC is only 26 bit.

so I will remove this and place my 100 MBit Castle card in (which should be 32 bit).

not got the machine here to test with but worth a try.
 
 
 

RISC OS 5.17 on an SA RiscPC

Post by Michae » Thu, 10 Feb 2011 05:51:02

Well it was the NIC causing the Abort

but now I get Message token * not found (Error number &AC2) and then the star prompt

which apparently refers to the softload tool not finding the ROM, which is odd because if I rerun !!softload it works??? weird.

I will join the ROOL forums to post the next issue :P no ADFS module in ROM

Thanks for the pointer to those forums!
 
 
 

RISC OS 5.17 on an SA RiscPC

Post by Chris Evan » Thu, 10 Feb 2011 21:45:27

In article < XXXX@XXXXX.COM >,


I doubt it, no incentive to do one :-(

I suspect ROOL might possibly be able to get the sources to the Castle NIC
but I'd be surprised if they have it allready or for any other NICs.



Chris Evans

--
CJE Micro's / 4D 'RISC OS Specialists'
Telephone: 01903 523222 Fax: 01903 523679
XXXX@XXXXX.COM http://www.yqcomputer.com/
78 Brighton Road, Worthing, West Sussex, BN11 2EN
The most beautiful thing anyone can wear, is a smile!
 
 
 

RISC OS 5.17 on an SA RiscPC

Post by Ron » Fri, 11 Feb 2011 07:37:27

In message < XXXX@XXXXX.COM >



I wonder if the Castle USB for RiscPC is 32bit? An option might be to use
the beagleboard USB network dongle.I imagine it would be slowish.

Ron M.
 
 
 

RISC OS 5.17 on an SA RiscPC

Post by Stace » Fri, 11 Feb 2011 17:47:52


No, you are correct, I had assumed that as it was purchased post Iyonix era it would be... Doh!

However I don't get an error with it until I tried to rmreinit the rom modules on the podule!
 
 
 

RISC OS 5.17 on an SA RiscPC

Post by Michae » Fri, 11 Feb 2011 19:09:25

Hmm, that was supposed to be posted as me!

Doh!
 
 
 

RISC OS 5.17 on an SA RiscPC

Post by Chris Evan » Fri, 11 Feb 2011 21:26:24

In article < XXXX@XXXXX.COM >, Ron




<echo on>
I doubt it, no incentive to do one :-(
<echo off>


and a lot of work, possible as much, maybe more than updating an Ether[?]
module without the sources?

Chris Evans

--
CJE Micro's / 4D 'RISC OS Specialists'
Telephone: 01903 523222 Fax: 01903 523679
XXXX@XXXXX.COM http://www.yqcomputer.com/
78 Brighton Road, Worthing, West Sussex, BN11 2EN
The most beautiful thing anyone can wear, is a smile!
 
 
 

RISC OS 5.17 on an SA RiscPC

Post by Steffen Hu » Sat, 12 Feb 2011 01:13:14


Sources for EtherY (Castle 100MBit NIC and podule) have long been
available.

http://www.yqcomputer.com/

Steffen

--
Steffen Huber - http://www.yqcomputer.com/
hubersn Software - http://www.yqcomputer.com/
 
 
 

RISC OS 5.17 on an SA RiscPC

Post by trev » Sat, 12 Feb 2011 06:09:17

> Sources for EtherY (Castle 100MBit NIC and podule) have long been

That's a handy link. I've included it in the ROOL wiki:
http://www.yqcomputer.com/ +Networking

If anyone gets anywhere with this, please update that page. Thanks.
 
 
 

RISC OS 5.17 on an SA RiscPC

Post by Michae » Sat, 12 Feb 2011 06:20:00


Cheers to both of you for that, I have successdully updated the card to 32-bit, and also found out that RISC OS 5 does not support ADFS nor Networking ;@) doh!
 
 
 

RISC OS 5.17 on an SA RiscPC

Post by Dave Higto » Sat, 12 Feb 2011 07:02:23

In message < XXXX@XXXXX.COM >



John Ballance did tell me that the Castle USB even works in the
Iyonix.

Dave
 
 
 

RISC OS 5.17 on an SA RiscPC

Post by Chris Evan » Sat, 12 Feb 2011 19:54:29

In article < XXXX@XXXXX.COM >,



Thanks for the info Steffen


Does that mean you recompiled the sources for 32bit?


:-(


Chris Evans

--
CJE Micro's / 4D 'RISC OS Specialists'
Telephone: 01903 523222 Fax: 01903 523679
XXXX@XXXXX.COM http://www.yqcomputer.com/
78 Brighton Road, Worthing, West Sussex, BN11 2EN
The most beautiful thing anyone can wear, is a smile!
 
 
 

RISC OS 5.17 on an SA RiscPC

Post by Jess » Sat, 12 Feb 2011 20:25:39

In message < XXXX@XXXXX.COM
glegroups.com>



I tried a version several months ago, and I'm sure that could read the
hard drive.

--
Jess Iyonix