VNC Server

VNC Server

Post by markusher9 » Fri, 26 Oct 2007 21:57:30


Hi all

I have been trying desperately to get VNC Server on RISC OS 3.71 to
work on
a Strongarm RISC PC.

I have been trying versions 0.08 and 0.10 but they just won't go.
A click on Start doesn't seem to do anything, or sometimes brings up
an
error "abort data transfer"

Has anyone got any advice. TCP/IP connectivity seems to be fine. I can
browse, ftp, ping etc etc.

Perhaps I have a module that is out of date. Toolbox unplugged or
something.
I am really at a loss to know where the problem is and would
appreciate some
help if anyone has any ideas.

-Mark
 
 
 

VNC Server

Post by New » Fri, 26 Oct 2007 22:23:38

In article < XXXX@XXXXX.COM >,




I have server module version 0.08 satisfactorily connecting my SARPC to my
Iyonix.

I also connect to Windows m/cs from the Iyon

I did have to fiddle with the port number a bit, but that was to get the
Windows m/c connecting IIRC.

The port number is specified in the startVNC obey file I have in the
SARPC(slave m/c)s Tasks file, and mine is as follows (password starred-out):


||

Set VNCServer$Dir <Obey$Dir>.^.Predesk

|| first make sure the vncserver module is installed
RMEnsure vncserver 0.00 RMLoad <VNCServer$Dir>.vncserver

|| start up the server (args are port no. and password)
vncserv_start 5901 ******

|| connect the VNC server's input to the mouse and keyboard
vncserv_mouse_kbd

| arg : 1 to swap adjust/menu or 0 to not swap
|vncserv_swap_adjust_menu 1


I can't remember now how I did that bit on the Windows m/c, but that's
probably/possibly not relevant to your situation.

The other thing which stops it working is to have your slave m/c screen
mode more than 256 colours - that won't work - and the colour results
aren't true anyway. But you can't have everything!

John

--
John Williams, Brittany, Northern France - no attachments to these addresses!
Non-RISC OS posters change user to johnrwilliams or put 'risc' in subject
for reliable contact! Who is John Williams? http://www.yqcomputer.com/
Somewhere nice to stay in Brittany? http://www.yqcomputer.com/

 
 
 

VNC Server

Post by druc » Sat, 27 Oct 2007 03:03:56


I've not been able to get any VNC server running on my Risc PC for
quite a while. I don't know if it was Select 3 or the ViewFinder that
causes problems. I'd certainly appreciate one that works with RO6.

---druck

--
The ARM Club Free Software - http://www.yqcomputer.com/
The 32bit Conversions Page - http://www.yqcomputer.com/
 
 
 

VNC Server

Post by Michael Em » Sat, 27 Oct 2007 03:22:01


I have found that (from the PC side of things) RealVNC is the only one
to work as TIGHT VNC cause an error like this (although it's supposed to
jsut return that the server cannot use tight encodings
 
 
 

VNC Server

Post by new » Sat, 27 Oct 2007 05:29:58

In article < XXXX@XXXXX.COM >,


Agreed. I've tried various VNCservers on an IYONIX and they all crash
horribly within a second or two.

Steve

--
Steve Revill @ Home
Note: All opinions expressed herein are my own.
 
 
 

VNC Server

Post by New » Sat, 27 Oct 2007 05:49:19

In article < XXXX@XXXXX.COM >,



I know Select broke a few things (!), but I suspect you wouldn't be running
your ViewFinder card in 256 colours, so that might be a problem!

John

--
John Williams, Brittany, Northern France - no attachments to these addresses!
Non-RISC OS posters change user to johnrwilliams or put 'risc' in subject
for reliable contact! Who is John Williams? http://www.yqcomputer.com/
Somewhere nice to stay in Brittany? http://www.yqcomputer.com/
 
 
 

VNC Server

Post by Steve Pott » Mon, 29 Oct 2007 04:53:39

In message < XXXX@XXXXX.COM >





Druck 0.10 definitely works on 6.06 here on 2 Risc PCs.

--
StevePotts at blastzone DOT demon STOP co DOT uk (www.blastzone.demon.co.uk/)
Written on RISC OS.
http://www.yqcomputer.com/

--
Posted via a free Usenet account from http://www.yqcomputer.com/
 
 
 

VNC Server

Post by Steve Pott » Mon, 29 Oct 2007 04:58:14

In message < XXXX@XXXXX.COM >




Here I run the VNC Server 0.10 on RISC OS 6.06 in 32K Colours at 1024 x 768
and it works very well. I normally use a Client Windows XP UltraVNC to
control said Risc PC.

I don't customise any settings, just use defaults for colours etc. and it
works fine.

The only problem I have on all versions of the VNCServers I've tried with
RISC OS is that occasionally, the session drops and needs to be
re-established. I can live with that minor problem.

Now, I have experienced a problem getting the Server running on someone
else's machine and never really understood why it didn't work. In that case
it was a 4.39 Risc PC.

HTH.

--
StevePotts at blastzone DOT demon STOP co DOT uk (www.blastzone.demon.co.uk/)
Written on RISC OS.
http://www.yqcomputer.com/

--
Posted via a free Usenet account from http://www.yqcomputer.com/
 
 
 

VNC Server

Post by Steve Frya » Mon, 29 Oct 2007 06:46:47


< XXXX@XXXXX.COM >:


While my failures were on a 4.37 RiscPC with Viewfinder. Make of that
what you will...

--
Steve Fryatt - Leeds, England

http://www.yqcomputer.com/