Can ASP.NET 1.1 apps co-exist with ASP.NET 2.0 on the same server?

Can ASP.NET 1.1 apps co-exist with ASP.NET 2.0 on the same server?

Post by am9uZWZlc » Wed, 14 Feb 2007 05:59:01


It would seem that if a server has the flexibility to set 'PER SITE' the
version of ASP.NET, that it would be able to have applications that co-exist
in different versions -- Is this a safe assumption?

If so, what must our server-guys be doing to appropriately 'isolate' the
apps from being 'unavabilable'? By that, I mean, the performance seems to be
- whomever opens their application first (1.1 or 2.0) THAT is the deciding
factor as to what version of ASP.NET apps are allowed to run. If one moment
you can open your application, and another moment, you cannot, it seems to be
due to the fact that the 'other version' of ASP.NET is running at that time.
 
 
 

Can ASP.NET 1.1 apps co-exist with ASP.NET 2.0 on the same server?

Post by Alvin Brun » Wed, 14 Feb 2007 08:22:58

Your server guys need to go back to IIS and *re-map the application back to
its original framework version. For instance, opening 1.1 sets the web site
to service requests under 1.1 and vice-versa. It's not really the fault of
the framework, it's more IIS at fault. You can fix this with a config file
<requiredruntime> property i belive change but the IIS is easier.

--
Regards,
Alvin Bruney
------------------------------------------------------
Shameless author plug
Excel Services for .NET is coming...
OWC Black book on Amazon and
www.lulu.com/owc
Professional VSTO 2005 - Wrox/Wiley