ASp.NET 2.0 consumes ASp.NET 1.1 web service

ASp.NET 2.0 consumes ASp.NET 1.1 web service

Post by R1I » Wed, 13 Sep 2006 02:30:02


I have web services which was developed by third party. I Need to consume the
web services.

I am using ASP.NEt 2.0. But the web services are in 1.1.
So I developed in ASp.NET 1.1. I receive the error:
System.web.services.protocols.SoapException: Root element is missing.

I really need immediate help from any one in this forum.
1. Why I receive this Soap Exception error in 1.1?
2. How can I make compatible with 1.1 web services. Just I need to all 1.1
web services from 2.0.
3. Do I need to install 1.1 and 2.0 on the server? Does it affect any other
applications running 1.1?

Any suggestions would be appreciated.
Thank you very much
 
 
 

ASp.NET 2.0 consumes ASp.NET 1.1 web service

Post by John Saund » Wed, 13 Sep 2006 20:41:13


Why do you believe that this error is specific to 1.1?

John

 
 
 

ASp.NET 2.0 consumes ASp.NET 1.1 web service

Post by www.EduJin » Fri, 15 Sep 2006 01:17:36

> I really need immediate help from any one in this forum.

Check the response. There's a problem in response... probably some fault!


There's nothing like 1.1 compatible or 2.0 compatible web services.
May be that the server-side users some extensions (WSE)...?


Frankly speaking... it's impossible to guess from whatever you wrote.
Probably, you can provide the WSDL (put up on some website - just wsdl - for
us to see).



--
Happy Hacking,
Gaurav Vaish | http://www.yqcomputer.com/
http://www.yqcomputer.com/
http://www.yqcomputer.com/
-------------------
 
 
 

ASp.NET 2.0 consumes ASp.NET 1.1 web service

Post by S2V2aW4gQn » Wed, 27 Sep 2006 00:09:01

But if IIS is running 1.1 and you are trying to use (configure 2.0) I have
run into the following error that shows up in my event log after a failed
call:

It is not possible to run two different versions of ASP.NET in the same IIS
process. Please use the IIS Administration Tool to reconfigure your server to
run the application in a separate process.
 
 
 

ASp.NET 2.0 consumes ASp.NET 1.1 web service

Post by www.EduJin » Thu, 28 Sep 2006 03:06:46

> It is not possible to run two different versions of ASP.NET in the same

Not sure which version of IIS you are using.

I am working with IIS 5.1 on WinXP.
One application uses ASP.Net 1.1 and another one users ASP.Net 2.0
And they work wonderfully fine.


--
Happy Hacking,
Gaurav Vaish | http://www.yqcomputer.com/
http://www.yqcomputer.com/
http://www.yqcomputer.com/
-------------------
 
 
 

ASp.NET 2.0 consumes ASp.NET 1.1 web service

Post by q » Thu, 28 Sep 2006 05:16:55

Sounds like you're trying to use .NET 1.1 assemblies in a .NET 2.0 app.
Get the source code and recompile. (or use reflector and recompile).

Other than that you can setup another website and have one 1.1 and the
other 2.0. Then you can interop anything you want. That's the entire
point of web services.