DataGrid bug in Framework 1.0, please confirm

DataGrid bug in Framework 1.0, please confirm

Post by QWxsYW4gTm » Wed, 26 May 2004 16:41:09


H
could some one please confirm this as a bug in the .net framework 1.0

place a datagrid on a winform, do databinding to you favorite database(northwind:)
press shift key down while pressing the arrow down. keep doing this until you reach the end, then keep doing this again a couple of times, then press the up arrow

this will result in the following exception

System.IndexOutOfRangeException: Index was outside the bounds of the array

at System.Windows.Forms.DataGrid.ProcessGridKey(KeyEventArgs ke
at System.Windows.Forms.DataGrid.ProcessDialogKey(Keys keyData
at System.Windows.Forms.Control.PreProcessMessage(Message& msg
at System.Windows.Forms.ThreadContext.System.Windows.Forms.UnsafeNativeMethods+IMsoComponent.FPreTranslateMessage(MSG& msg

Would some one please confirm this
best regards Allan
 
 
 

DataGrid bug in Framework 1.0, please confirm

Post by Claes Berg » Wed, 26 May 2004 19:05:17

Yes, it's a bug. It's been fixed in 1.1

/claes



database(northwind:).
you reach the end, then keep doing this again a couple of times, then press
the up arrow.
array.
System.Windows.Forms.ThreadContext.System.Windows.Forms.UnsafeNativeMethods+
IMsoComponent.FPreTranslateMessage(MSG& msg)

 
 
 

DataGrid bug in Framework 1.0, please confirm

Post by QWxsYW4gTm » Wed, 26 May 2004 21:56:06

thank you so much for this confirmation here
you would not have a link to MS where this is explicit confirmed :)
cheers Allan
 
 
 

DataGrid bug in Framework 1.0, please confirm

Post by Claes Berg » Thu, 27 May 2004 17:18:25

No. I'm not aware of an official MS comment on this.
It has been confirmed by others in these newsgroups though.

/claes