Not able to run ASP.Net applications-Error in ASP.Net

Not able to run ASP.Net applications-Error in ASP.Net

Post by U2h5YW » Tue, 12 Apr 2005 18:00:02


Hi,

I've a serious problem in running a ASP.net application.
I've installed .net framework 1.1 on Windows 2003 server. When i try to open
an Web application, i receive the following errors.

1.The Web was created successfully,but an error occured when trying to
configure the application root for this web.Web projects may not operate
correctly without an application root. The returned error was: A possible
cause of this eror is insufficient access rights to perform the operation.
You can manually configure the
application root using the Internat Services Mgr.

Kindly help me

Regards,
Shyam
 
 
 

Not able to run ASP.Net applications-Error in ASP.Net

Post by UmFrZXNoIF » Tue, 12 Apr 2005 20:43:01

Hi Shyam,

Windows 2003 Server has a lot of security settings. And doing it the first
time can be a bit tedious.

These are what come to my mind:
1. Add your site to the trusted sites list (AFAIK, it's in the File menu of
IE)
2. If you also have .NET 2.0 installed, then you might have to disable it
and make .NET 1.1 as the default one instead. You can do this in the
IIS->Admin options->ASP.NET dialog
3. You might have to allow ASP.NET requests. Click on the "Allow" button in
one of the root pages in the IIS MMC console (i don't remember which page :(
).

Sorry, I don't have a Win 2k3 machine nearby to specify the exact menu's and
windows...hope you will be able to find them out.

Let me know if you need more assistance.

HTH,
Rakesh Rajan

 
 
 

Not able to run ASP.Net applications-Error in ASP.Net

Post by U2h5YW » Wed, 13 Apr 2005 02:19:03

Hi,

I haven't installed .net framework 2.0. Also, all the root pages are
"Allowed" and are running fine. Checked the same with the "Services" that are
running in the system(Administrative Tools),where the Status="Started".
Kindly help me!

Thanks,
Shyam
 
 
 

Not able to run ASP.Net applications-Error in ASP.Net

Post by UmFrZXNoIF » Wed, 13 Apr 2005 11:27:01

Hi Shyam,

Did you add your site to the trusted sites list?

If that doesn't work, also try running aspnet_regiis -i.

Is this the first time you are trying to develop web apps in this machine -
in other words, was it working fine before?

Do you have any other server s/w installed in the machine (like SharePoint
etc.)?

HTH,
Rakesh Rajan
 
 
 

Not able to run ASP.Net applications-Error in ASP.Net

Post by U2h5YW » Wed, 13 Apr 2005 17:10:02

i Rakesh,

No,there is no other server s/w that is installed. Earlier,i had installed
WinXP,in which it was working fine..but now,it isn't.let me know, how should
i run the "aspnet_regiis -i"?
is it in the .Net comand prompt? Also,it would be really helpful,if you can
let me know how to add the "Trusted Site" in the IE(as you mentioned in your
previous reply,
1. Add your site to the trusted sites list (AFAIK, it's in the File menu of
IE)...
Kindly help me!

Thanks,
Shyam

"Rakesh Rajan" wrote:

 
 
 

Not able to run ASP.Net applications-Error in ASP.Net

Post by UmFrZXNoIF » Wed, 13 Apr 2005 17:59:02

i Shyam,

Open a new IE window, and navigate to your web application page. Click on
the File menu and then click on the Trusted Sites. Add the your web
application's path to the Trusted Zone list. (These are the menu names as I
remember - there may be slight differences)


Goto C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\ in cmd.exe.
Then execute aspnet_regiis -i
This would re-register ASP.NET etc.

Let me know if this helps.

HTH,
Rakesh Rajan


"Shyam" wrote: