VS .Net cde behind files missing

VS .Net cde behind files missing

Post by Dan » Mon, 09 May 2005 05:09:47


When i create a new aspx file in VS.NET 2002 no code behind file is created.
Instead, the aspx file is created with this at the top:

<%@ Page Language="vb" AutoEventWireup="false" Codebehind="$FILENAME$.vb"
Inherits="$INHERITS$"%>

Additionally, the HTML Editor is not available to edit files and no
intellisense is working for asp (vbscript) files. In short the installation
is completely corrupted.

I have tried repairing the installation, uninstalling and reinstalling the
software to no avail. I have also reapplied SP1 with no effect.

I have tried running:

"%windir%\microsoft.net\framework\v1.0.3705\aspnet_regiis.exe" -i

from the command prompt as this was a recommended fix but this has had no
effect.

Any ideas?

Thanks in advance

Dan
 
 
 

VS .Net cde behind files missing

Post by Scott M » Mon, 09 May 2005 11:23:43

It sounds like the "template" project files may be corrupted or missing. I
would re-install VS.NET.

 
 
 

VS .Net cde behind files missing

Post by Dan » Mon, 09 May 2005 15:34:31

As i say, i hve reinstalled VS.NET (several times) together with .NET
Framework. I have also followed instructions to delete Reg Keys relevant to
VS.NET and .NET Framework - nothing works.

Dan
 
 
 

VS .Net cde behind files missing

Post by Scott M » Mon, 09 May 2005 23:29:48

Where does your copy of VS.NET come from? Are you sure it is an authentic
copy? If it is, you may have a damaged disc. You could contact MS for
replacement media.