CW 5.1.1 and CW 5.8

CW 5.1.1 and CW 5.8

Post by feli » Thu, 16 Feb 2006 10:28:28


I am using CodeWarrior with Version 5.1.1 build 1108 to create a bundle
initially. My application can call the bundle successfully.
Now, I downloaded CodeWarrior Version 5.8 build 1919 to compile my old
program. After I compile my old project and create a new bundle, my
application fail to call the bundle.
Is that any change need in my setting so that my new bundle will work?

Felix
 
 
 

CW 5.1.1 and CW 5.8

Post by Chri » Sat, 18 Feb 2006 23:49:03

Check Info.plist for key: CFBundleIdentifier.
Check path to pluginfolder. Depands on how you find your bundle.

Chris

 
 
 

CW 5.1.1 and CW 5.8

Post by larr » Tue, 21 Feb 2006 03:33:20


Exactly what do you mean when you say "call a bundle?" Are you getting
any errors returned in the code that's failing? I'm sure it's not an
issue with the IDE and you don't really give any useful information to
identify the problem.

Larry
 
 
 

CW 5.1.1 and CW 5.8

Post by feli » Tue, 21 Feb 2006 17:22:31

Hi Larry,

"Call a bundle" mean that the application will load some data from my
bundle. The application do not show any error message and the
application is not written by me. It show the message that the
application quit unexpectedly.
I don't know what's the problem.

Regards,
Felix
 
 
 

CW 5.1.1 and CW 5.8

Post by feli » Tue, 21 Feb 2006 17:26:14

Hi Chris,

I check the info.plist for key : CFBundleIdentifier are the same for
both projects.
Since I only write program for the bundle, not for the application, I
don't know how the application find my bundle.

Regards,
Felix
 
 
 

CW 5.1.1 and CW 5.8

Post by Chri » Wed, 22 Feb 2006 17:31:31

Hi,
look for the MAC OS X Examples. There ist a example for bundle.
Then you can compile an application and check your bundle from the
other side.
If this works, you can do something other wrong. It depends on the
interface that the other programmer has implementet.
Regards
Chris