Can't compile with 8.3 and Panther

Can't compile with 8.3 and Panther

Post by Bint » Mon, 27 Oct 2003 03:29:12


Hello,

Using Panther now, I just tried to compile my app and I get header compile
include errors. For example,

Error : ';' expected
(included from:
Movies.h:24
MediaHandlers.h:24
Quicktime.h:30
Engine.h:74
main.cpp:1)
ImageCompression.h line 4990 UInt32 flags)
AVAILABLE_MAC_OS_X_VERSION_10_3_AND_LATER;


What is the fix for this?

Thanks!
Bint
 
 
 

Can't compile with 8.3 and Panther

Post by Sean McBri » Mon, 27 Oct 2003 05:14:27

In article <BBC02B2F.CB5C% XXXX@XXXXX.COM >, Bint < XXXX@XXXXX.COM >



Looks like this is going to be asked a lot. :(

The 10.3 headers changed and CW doesn't like some of the changes. But
you can repoint the "OS X Volume" source tree to the OS 10.2 headers
(install the SDKs with the 10.3 dev tools).

 
 
 

Can't compile with 8.3 and Panther

Post by Bint » Mon, 27 Oct 2003 06:04:13

Sorry to be dense, but maybe others will wonder this:

How exactly do you do this? I don't have much experience with low-level
CodeWarrior/compile stuff.

For example, where are the OS 10.2 headers and how do you repoint the "OS X
Volume" source tree?

Thanks a lot for your help!
Bint



On 10/25/03 3:14 PM, in article
XXXX@XXXXX.COM , "Sean McBride"
 
 
 

Can't compile with 8.3 and Panther

Post by Sean McBri » Mon, 27 Oct 2003 08:17:03

In article <BBC04F99.CC94% XXXX@XXXXX.COM >, Bint < XXXX@XXXXX.COM >



I don't remember, somewhere in /Developer. Do a custom install of the
XCode dev tools, I'm not sure they are installed by default.


Open CW, Edit > Preferences > General > Source Trees
 
 
 

Can't compile with 8.3 and Panther

Post by Bint » Mon, 27 Oct 2003 08:40:42

Thanks!
B


On 10/25/03 6:17 PM, in article
XXXX@XXXXX.COM , "Sean McBride"
 
 
 

Can't compile with 8.3 and Panther

Post by Miro Juris » Mon, 27 Oct 2003 14:45:00

In article < XXXX@XXXXX.COM >,




/Developers/SDKs/MacOSX10.2.7.sdk

They are definitely not isntalled by default.

hth

meeroh

--
If this message helped you, consider buying an item
from my wish list: < http://www.yqcomputer.com/ ;