Is there anyway Vpython and pyODE can be made to work with newer versions of Python 2.6.1 etc. without a lot of changes to source code?

Is there anyway Vpython and pyODE can be made to work with newer versions of Python 2.6.1 etc. without a lot of changes to source code?

Post by Gerhard Hi » Mon, 26 Jan 2009 06:27:03



Aren't this just Python libraries that include extension modules (i. e.
modules written in C to interface external C libraries). If so, there is
a good chance that just compiling them against Python 2.6 works out of
the box. Otherwise the adjustments necessary will be just minor ones.

Python 3.0 compatibility is a different issue, though (more work).

-- Gerhard