ActiveSync 4.1 does not offer DMA connection to emulator

ActiveSync 4.1 does not offer DMA connection to emulator

Post by Rene Ruppe » Sat, 04 Feb 2006 08:44:42


Hi,

I'm rather new to Visual Studio 2005. I wrote a small WebService and tried
to call it within the PPC 2003 SE emulator but without succes. Sneaking
around on the web I figured out that ActiveSync has to be installed. I
accidently installed version 3.8 instead of 4.1 but at least the emulator
was detected when I set it to be cradled.

Shortly after this I uninstalled 3.8 and installed ActiveSync 4.1 - now the
emulator won't be detected any longer. In the connection combobox of
ActiveSync I can only choose between "COM1" and "COM5". There is no such
thing like a "DMA" entry.

Damn, this has been bugging me for too long...any hints are welcome!

Regards,

Ren
 
 
 

ActiveSync 4.1 does not offer DMA connection to emulator

Post by Ginny Caug » Sat, 04 Feb 2006 10:02:32

Rene,

This sort of problem was fairly commonplace with VS 2003 and uninstalling
and then reinstalling Activesync. I haven't run into it with VS 2005, but
this looks like the solution:
http://www.yqcomputer.com/
might save you from having to reinstall VS 2005.

--
Ginny Caughey
.NET Compact Framework MVP

 
 
 

ActiveSync 4.1 does not offer DMA connection to emulator

Post by Rene Ruppe » Sat, 04 Feb 2006 17:11:24

Thanks alot!
It worked!

To help others on this topic I copy the solution from MSDN to this group:

This usually happens if the ActiveSync plugin is not registered properly.
You can try one of the following and see whether it fixes the problem.

1. Restart AS or machine - to restart AS kill wcescomm.exe

(If the above didn't fix the problem try the following)
2. Uninstall AS and reinstall it again

(If problem still not solved try this)
3. Manually register the emulator and AS plugin. Execute the following
commands on a cmd shell
a. devicemulator.exe /register
b. dvcemumanager.exe /register
c. regsvr32 deviceemulatorproxy.dll
d. regsvr32 serdmaasplugin.dll
e. regsvr32 deviceemulatorbootstrap.dll

The .exe and .dll files could be found under "C:\Program Files\Microsoft
Device Emulator\1.0" assuming VS is installed under C: drive.

deviceemulatorbootstrap.dll could be found under "C:\Program Files\Microsoft
Visual Studio 8\SmartDevices\Emulators\DeviceEmulator"

After performing the above steps, restart AS.
 
 
 

ActiveSync 4.1 does not offer DMA connection to emulator

Post by Rene Ruppe » Sat, 04 Feb 2006 20:27:24

Right now another problem occurs: whenever I close the emulated device and
turn it back on again, AS won't recognize it. I have to go to the
connections menu and connect manually...that's annoying....maybe
reinstalling the whole stuff is the best solution.

Ren