How to get back deleted web parts and populate Web Part Page G

How to get back deleted web parts and populate Web Part Page G

Post by UmFq » Sat, 14 May 2005 04:08:05


Wei-Dong XU,

I can't find that Members web part in any of Web Part Galleries and it was
totally disappeared. Is there way to populate that web part in 'Site Gallery'
or 'Web Part Page Gallery'?

Thanks,
Raj
 
 
 

How to get back deleted web parts and populate Web Part Page G

Post by UmFq » Sat, 14 May 2005 04:08:08

Wei-Dong XU,

I can't find that Members web part in any of Web Part Galleries and it was
totally disappeared. Is there way to populate that web part in 'Site Gallery'
or 'Web Part Page Gallery'?

 
 
 

How to get back deleted web parts and populate Web Part Page G

Post by v-wdx » Sat, 14 May 2005 12:53:16


Hi Raj,

Members web part is the built-in one of WSS. If you removed it, you should
only remove the member dwp from the web part gallery and the component is
still located at the server. So I'd suggest you can upload the dwp file to
the gallery so that WSS site can populate it then. I attach the file in
this post.

Please feel free to let me know if any question. It is my pleasure to be of
any assistance.

Best Regards,
Wei-Dong XU
Microsoft Product Support Services
This posting is provided "AS IS" with no warranties, and confers no rights.

{\rtf1\ansi\ansicpg936\deff0\deflang1033\deflangfe2052{\fonttbl{\f0\froman\fprq2\fcharset0 Bookman Old Style;}}
\viewkind4\uc1\pard\lang2052\f0\fs23 Hi Raj,
\par
\par Members web part is the built-in one of WSS. If you removed it, you should only remove the member dwp from the web part gallery and the component is still located at the server. So I'd suggest you can upload the dwp file to the gallery so that WSS site can populate it then. I attach the file in this post.
\par
\par Please feel free to let me know if any question. It is my pleasure to be of any assistance.
\par
\par Best Regards,
\par Wei-Dong XU
\par Microsoft Product Support Services
\par This posting is provided "AS IS" with no warranties, and confers no rights.
\par
\par
\par }
 
 
 

How to get back deleted web parts and populate Web Part Page G

Post by v-wdx » Sat, 14 May 2005 12:55:10


Hi Raj,

Furthermore, if you are using the web-based newsgroup reader, you will not
obtain the attachment at the above reply. Since the dwp file is essentially
one xml file, I paste the content of this file for you here:
//--------------------------------------------------------------------------
-
<?xml version="1.0" encoding="utf-8" ?>
- <!-- _lcid="1033" _version="11.0.5510" _dal="1"
-->
- <WebPart xmlns=" http://www.yqcomputer.com/ ">
<Assembly>Microsoft.SharePoint, Version=11.0.0.0, Culture=neutral,
PublicKeyToken=71e9bce111e9429c</Assembly>
<TypeName>Microsoft.SharePoint.WebPartPages.MembersWebPart</TypeName>
<Title>Members</Title>
<Description>Use the Members Web Part to see a list of the site members
and their online status.</Description>
<PartImageLarge>/_layouts/images/msmeml.gif</PartImageLarge>
</WebPart>
//--------------------------------------------------------------------------
-

Please feel free to let me know if you have any question.

Best Regards,
Wei-Dong XU
Microsoft Product Support Services
This posting is provided "AS IS" with no warranties, and confers no rights.

{\rtf1\ansi\ansicpg936\deff0\deflang1033\deflangfe2052{\fonttbl{\f0\froman\fprq2\fcharset0 Bookman Old Style;}}
\viewkind4\uc1\pard\lang2052\f0\fs23 Hi Raj,
\par
\par Furthermore, if you are using the web-based newsgroup reader, you will not obtain the attachment at the above reply. Since the dwp file is essentially one xml file, I paste the content of this file for you here:
\par //---------------------------------------------------------------------------
\par <?xml version="1.0" encoding="utf-8" ?>
\par - <!-- _lcid="1033" _version="11.0.5510" _dal="1"
\par -->
\par - <WebPart xmlns=" http://www.yqcomputer.com/ ">
\par <Assembly>Microsoft.SharePoint, Version=11.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c</Assembly>
\par <TypeName>Microsoft.SharePoint.WebPartPages.MembersWebPart</TypeName>
\par <Title>Members</Title>
\par <Description>Use the Members Web Part to see a list of the site members and their online status.</Description>
\par <PartImageLarge>/_layouts/images/msmeml.gif</PartImageLarge>
\par </WebPart>
\par //---------------------------------------------------------------------------
\par
\par Please feel free to let me know if you have any question.
\par
\par Best Regards,
\par Wei-Dong XU
\par Microsoft Product Support Services
\par This posting is provided "AS IS" with no warranties, and confers no rights.
\par
\par
\par }
 
 
 

How to get back deleted web parts and populate Web Part Page G

Post by UmFq » Sat, 14 May 2005 22:01:11

Wei-Dong XU,

Let me clarify few things with you first.
I have about 110 sub sites, and most of the sites display site members using
Members web part. But just one site acts totally different than rest. On this
site the Member web part lost vertical scroll bar and this page became too
big to scroll. To avoid this issue, I have deleted Members web part from the
sub site. Following are the steps I performed.
1. Modify Share Web Part
2. Delete
I am sure this action is not going to delete the component at server level
and this action should not delete the web part from the web part gallery too.
But the issue is I don see this member web part in any of galleries. I
tried with your DWP file and that is not working either. Can you please
explain why it is causing this problem and if possible please send me the DWP
through email.

Thanks,
Raj
 
 
 

How to get back deleted web parts and populate Web Part Page G

Post by v-wdx » Tue, 17 May 2005 16:58:58

Hi Raj,

Thanks for the detailed information!

"Can you please explain why it is causing this problem"
From your steps, I don't think you have deleted it. You should close it
from the page. However, since I can't reproduce this, I can't figure out
the cause. So it will be necessary for locating the root cause to perform
one trace or live debugging on the SPS at your box, which is suggested to
be operated in one support incident at your Microsoft local PSS. Before
that, at community, currently I have one suggestion for you:
1. backup your site (stsadm)
2. remove the site
3. create one new site with the same URL once more
4. restore the data back into the new site.
* please note, this operation may affect your business, I'd suggest please
backup the whole potal in case any disaster failure.
After that, please verify whether the member web parts appears.

Furthermore, I have another idea. Since only one site at your 110 sites met
such one odd issue, I can write one web part for you to list the members of
the site. This way, you only need to deploy this web part at your site and
forget the built-in members. If you like this idea, please feel free to let
me know.

"I tried with your DWP file and that is not working either."
In addition, the dwp file I obtained from my site has the same content as
the previous post. Since it is failed, I think this troubleshooting
suggestion is helpless. Please consider the two above.

Look forward to your reply! My pleasure to be of any assistance with you!

Best Regards,
Wei-Dong XU
Microsoft Product Support Services
This posting is provided "AS IS" with no warranties, and confers no rights.

{\rtf1\ansi\ansicpg936\deff0\deflang1033\deflangfe2052{\fonttbl{\f0\froman\fprq2\fcharset0 Bookman Old Style;}{\f1\froman\fprq2\fcharset134 \'cb\'ce\'cc\'e5;}}
\viewkind4\uc1\pard\lang2052\f0\fs23 Hi Raj,
\par
\par Thanks for the detailed information!
\par
\par "Can you please explain why it is causing this problem"
\par From your steps, I don't think you have deleted it. You should close it from the page. However, since I can't reproduce this, I can't figure out the cause. So it will be necessary for locating the root cause to perform one trace or live debugging on the SPS at your box, which is suggested to be operated in one support incident \f1\fs22 at your Microsoft local PSS\f0\fs23 . \f1\fs22 Before that, at community, c\f0\fs23 urrently I have one suggestion for you:
\par 1. backup your site (stsadm)
\par 2. remove the site
\par 3. create one new site with the same URL once more
\par 4. restore the data back into the new site.
\par * please note, this operation may affect your business, I'd suggest please backup the whole potal \f1\fs22 in case any disaster failure. \f0\fs23
\par \f1\fs22 After that, please verify whether the member web parts appears.
\par
\par Furthermore, I have another idea. Since only one site at your 110 sites met such one odd issue, I can write one web part for you to list the members of the site. This way, you only need to deploy this web part at your site and forget the built-in members. If you like this idea, please feel free to let me know.
\par
\par "I tried with your DWP file and that is not working either."
\par In addition, the dwp file I obtained from my site has the same content as the previous post. Since it is failed, I think this troubleshooting suggestion is helpless. Please consider the two
 
 
 

How to get back deleted web parts and populate Web Part Page G

Post by UmFq » Tue, 17 May 2005 21:54:01

Wei-Dong XU,

Thanks for your reply. I really can not perform your first suggestion due to
following reasons.

1. Since this site is sub site and I really can not backup any sub site
using STSADM tool unless you have any way to do it.

2. Even if it is top level site and if you backup using STSADM and restore
it back you loose all users for that site and their configuration.

Probably writing web part looks the only solution at this time. But still I
am not convinced why Members web part disappeared from this sub site. I can
grant you the access to our test box, if you would like to debug. Please let
me know your option.

Thanks again,
Raj
 
 
 

How to get back deleted web parts and populate Web Part Page G

Post by v-wdx » Wed, 18 May 2005 18:02:08


Hi Raj,

Due to the support policy at the community, it is better for me to write
one web part for you. The live debugging is supported at one case in your
local Microsoft PSS.

After my development, I will attach the source code here and for your
convenience, please send one mail to me so that I can mail this to you
directly. My email address is: XXXX@XXXXX.COM (please remove
the online which is used to avoid the spam)

My pleasure to be of any assistance.

Best Regards,
Wei-Dong XU
Microsoft Product Support Services
This posting is provided "AS IS" with no warranties, and confers no rights.

{\rtf1\ansi\ansicpg936\deff0\deflang1033\deflangfe2052{\fonttbl{\f0\froman\fprq2\fcharset0 Bookman Old Style;}{\f1\froman\fprq2\fcharset134 \'cb\'ce\'cc\'e5;}}
\viewkind4\uc1\pard\lang2052\f0\fs23 Hi Raj,
\par
\par Due to the support policy at the community, it is better for me to write one web part for you. The live debugging is supported at one case in your local Microsoft PSS.
\par
\par After my development, I will attach the source code here and for your convenience, please send one mail to me so that I can mail this to you directly. My email address is: XXXX@XXXXX.COM (please remove the online which is used to avoid the spam)\f1\fs22
\par \f0\fs23
\par My pleasure to be of any assistance.
\par
\par Best Regards,
\par Wei-Dong XU
\par Microsoft Product Support Services
\par This posting is provided "AS IS" with no warranties, and confers no rights.
\par
\par
\par }
 
 
 

How to get back deleted web parts and populate Web Part Page G

Post by v-wdx » Thu, 19 May 2005 21:21:34


Hi Raj,

My Members web part for you is attached at this thread. Please use outlook
express to read the newsgroup so that you can download this attachment. At
the Web-based newsgroup reader, we can't download the attachment. Microsoft
nntp newsreader server is:
msnews.microsoft.com

Please feel free to let me know if you have any question. I will be more
than happy to be of any assistance.

Best Regards,
Wei-Dong XU
Microsoft Product Support Services
This posting is provided "AS IS" with no warranties, and confers no rights.

{\rtf1\ansi\ansicpg936\deff0\deflang1033\deflangfe2052{\fonttbl{\f0\froman\fprq2\fcharset0 Bookman Old Style;}}
\viewkind4\uc1\pard\lang2052\f0\fs23 Hi Raj,
\par
\par My Members web part for you is attached at this thread. Please use outlook express to read the newsgroup so that you can download this attachment. At the Web-based newsgroup reader, we can't download the attachment. Microsoft nntp newsreader server is:
\par msnews.microsoft.com
\par
\par Please feel free to let me know if you have any question. I will be more than happy to be of any assistance.
\par
\par Best Regards,
\par Wei-Dong XU
\par Microsoft Product Support Services
\par This posting is provided "AS IS" with no warranties, and confers no rights.
\par
\par
\par }