OWA 2003 Front End Server with Forms Authentication wont work with Exchange 2000 Backend.

OWA 2003 Front End Server with Forms Authentication wont work with Exchange 2000 Backend.

Post by ash » Thu, 20 May 2004 04:02:11


We have a centralised OWA server providing webmail for all locations
in our organisation. This was up until yesterday configured as

Front End Exchange 2003 w/forms based authentication
Windows 2000 Server

Our sites in the US and UK had backend servers that were running
WIndows 2003 and Exchange 2003. Our Australian location is still
running Exchange 2000 and Windows 2000.

I Upgraded the central FrontEnd server to Windows 2003.

Now the US and UK mailboxes continue to logon correctly when users
enter their UPN. (Australia and UK are subdomains of the US).

However, Australian users cannot logon to OWA. They get an HTTP/1.1
500 Internal Server Error when they enter their UPN.

Directory Security has domain and Realm set to '\' for the Exchange
and Exchweb Virtual Directory.

DOes anyone have any suggestions?

Thanks

Ash
 
 
 

OWA 2003 Front End Server with Forms Authentication wont work with Exchange 2000 Backend.

Post by Baris Eris » Thu, 20 May 2004 12:37:38

Exchange 2003 front-end servicing Exchange 2000 back-end scenario is not
supported. You must upgrade the back-end or make sure mailbox owners on that
server use a FE that is still Exchange 2000.

Baris.

--
This posting is provided "AS IS" with no warranties, and confers no rights.

 
 
 

OWA 2003 Front End Server with Forms Authentication wont work with Exchange 2000 Backend.

Post by Kevi » Fri, 21 May 2004 09:23:38

Baris, your answer is absolulely 100% wrong.

E2K3 front-ends can service E2K or E2K3 back-ends.

E2K front-ends can only service E2K back-ends. In fact, unless you
know how to fool SETUP, you'll never be able to end up with this
scenario anyway.
 
 
 

OWA 2003 Front End Server with Forms Authentication wont work with Exchange 2000 Backend.

Post by Baris Eris » Fri, 21 May 2004 11:34:59

Ahh my mistake, mis-typed the versions -- should have said "E2k FEs
servicing E2k3 BEs scenario is not supported", thanks for the correction
Kevin.

You can end up with E2k FE servicing E2k3 BE scenario if you have multiple
administrative groups; because setup only enforces version requirements at
the administrative group level.

Baris.

--
This posting is provided "AS IS" with no warranties, and confers no rights.
 
 
 

OWA 2003 Front End Server with Forms Authentication wont work with Exchange 2000 Backend.

Post by Kevi » Sun, 23 May 2004 08:22:46

It is also possible to introduce a new E2k3 OWA FE into an admin group
by temporarily unchecking "This is a front-end server" on the existing
E2k FE long enough to do the install. We did that because we wanted to
make sure the E2K3 OWA FE was functional before touching our
production E2K FE.

IMHO, SETUP should have included a switch to allow you to override
this restriction because having the new E2k3 FE introduced into an
existing admin group without touching anything production seems to be
a good deployment path.