Analysis Services Processing Task Not Doing a Full Process

Analysis Services Processing Task Not Doing a Full Process

Post by sara2thebr » Sun, 15 Feb 2004 03:29:23


I have a DTS package that is set up to process the dimensions
contained in my cubes. They are set to rebuild the dimension
structures (and process). I have another DTS package that is set to
process the cubes, and these are set to do a full process. However, I
recently changed some of the data in one of the dimension tables, ran
the packages that are supposed to rebuild the dimension structure and
do a full process of the cubes, but I did not see the changes
reflected within that dimension in the cube. I then re-ran the
packages: same thing. So I manually rebuilt and processed the
dimensions and did a full process of the cube. I then was able to see
the changes reflected in the cube. How is this possible? The DTS
Analysis Services Processing Task does not appear to be doing what it
says it is doing. By the way, I could not determine whether it was
the dimension that was not really being rebuilt or the cube that
wasn't really being fully re-processed, b/c I have too much data in
the dimension to see all of the data in the dimension when I choose
'browse data'...the data of concern was toward that bottom of the
list, and the end of the list said something like '(more members exist
than can be displayed)'. I do know, however that that relational
dimension table did show my changes. Can anyone tell me why the DTS
packages aren't doing what they should be doing? Thanks!
 
 
 

Analysis Services Processing Task Not Doing a Full Process

Post by nicksc » Mon, 01 Mar 2004 15:19:20

Hi
You may be running into the problem described in the following article:

834777 FIX: Some cubes are not processed by the process database operation
http://www.yqcomputer.com/

Nick Schueler
--------------------
| From: XXXX@XXXXX.COM (Sara)
| Newsgroups: microsoft.public.sqlserver.dts
| Subject: Analysis Services Processing Task Not Doing a Full Process
| Date: 13 Feb 2004 10:29:23 -0800
| Organization: http://www.yqcomputer.com/
| Lines: 21
| Message-ID: < XXXX@XXXXX.COM >
| NNTP-Posting-Host: 198.26.122.12
| Content-Type: text/plain; charset=ISO-8859-1
| Content-Transfer-Encoding: 8bit
| X-Trace: posting.google.com 1076696963 24714 127.0.0.1 (13 Feb 2004
18:29:23 GMT)
| X-Complaints-To: XXXX@XXXXX.COM
| NNTP-Posting-Date: Fri, 13 Feb 2004 18:29:23 +0000 (UTC)
| Path:
cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfeed00.su
l.t-online.de!t-online.de!news-spur1.maxwell.syr.edu!news.maxwell.syr.edu!po
stnews1.google.com!not-for-mail
| Xref: cpmsftngxa07.phx.gbl microsoft.public.sqlserver.dts:44423
| X-Tomcat-NG: microsoft.public.sqlserver.dts
|
| I have a DTS package that is set up to process the dimensions
| contained in my cubes. They are set to rebuild the dimension
| structures (and process). I have another DTS package that is set to
| process the cubes, and these are set to do a full process. However, I
| recently changed some of the data in one of the dimension tables, ran
| the packages that are supposed to rebuild the dimension structure and
| do a full process of the cubes, but I did not see the changes
| reflected within that dimension in the cube. I then re-ran the
| packages: same thing. So I manually rebuilt and processed the
| dimensions and did a full process of the cube. I then was able to see
| the changes reflected in the cube. How is this possible? The DTS
| Analysis Services Processing Task does not appear to be doing what it
| says it is doing. By the way, I could not determine whether it was
| the dimension that was not really being rebuilt or the cube that
| wasn't really being fully re-processed, b/c I have too much data in
| the dimension to see all of the data in the dimension when I choose
| 'browse data'...the data of concern was toward that bottom of the
| list, and the end of the list said something like '(more members exist
| than can be displayed)'. I do know, however that that relational
| dimension table did show my changes. Can anyone tell me why the DTS
| packages aren't doing what they should be doing? Thanks!
|