Errors while installing SP3a on Cluster SQL Instance

Errors while installing SP3a on Cluster SQL Instance

Post by Brett Cant » Sun, 21 Sep 2003 00:14:46


'm having an issue when running SP3a on a SQL Cluster.
The cluster is made up of two machines, DB1 and DB2. DB2
is the active node. I have placed all SP3a setup files in
c:\sql2ksp3 on DB2, and created a share for that
directory. In addition, the account I'm using to logon the
SQL Service (and the one I am logging onto the desktop) is
a Domain Admin. When I run the service pack setup, I get
the following error:
"Setup failed to perform required operations on the
clustered nodes"

Here's a copy of SQLSP.LOG:
NumRemoteServers=2
Server.1=GHPDB2
Server.2=GHPDB1
[Server.1]
NumRemoteServices=1
1.app="\\GHPDB2\C$\sql2ksp3\x86\setup\setupsql.exe"
1.server=GHPDB2
1.script=\\GHPDB2\admin$\GHPDB2_MSSQLSERVER.iss
1.cmdlineformat=%s k=Nb k=Rm k=Cl -SMS -s -f "\\GHPDB2
\C$\sql2ksp3\x86\setup\setup.ins" -f1 %s -f2 "\\GHPDB2
\admin$\setup.log" -e "stpsilnt._ex" -b -x "c:\temp\"
1.user=RAVGOVCON\clusteradmin
1.name=SQLSetup1
1.sqlsetup=Y
1.copyexe=cnvsvc1.exe
[Server.2]
NumRemoteServices=1
1.app="\\GHPDB2\C$\sql2ksp3\x86\setup\setupsql.exe"
1.server=GHPDB1
1.script=\\GHPDB2\admin$\GHPDB1_MSSQLSERVER.iss
1.cmdlineformat=%s k=ClSec k=Rm k=Cl -SMS -s -f "\\GHPDB2
\C$\sql2ksp3\x86\setup\setup.ins" -f1 %s -f2 "\\GHPDB1
\admin$\setup.log" -e "stpsilnt._ex" -x "C:\"
1.user=RAVGOVCON\clusteradmin
1.name=SQLSetup2
1.sqlsetup=Y
1.copyexe=cnvsvc2.exe
00:53:41 Setup is performing required operations on
cluster nodes. This may take a few minutes...
00:53:41 "c:\temp\SqlSetup\Bin\remsetup.exe"
C:\WINNT\remsetup.ini saEpwd
01:02:00 Process Exit Code: (5) Access is denied.

01:02:00 Begin Action : GetRemsetupRetCode
01:02:00 Installation return status on GHPDB2 : 3010
01:02:00 Installation return status on GHPDB1 : 5
01:02:00 End Action : GetRemsetupRetCode
#### SQL Server Remote Setup - Start Time 09/19/03
00:53:41 ####

CThreadPool::RunUntilCompleteHlpr create thread, index=0
CThread::Run thread [0x94] created for execution.
CThread::Process [0x94]
CThreadPool::RunUntilCompleteHlpr create thread, index=1
CThread::Run thread [0x98] created for execution.
CThread::Process [0x98]
CThreadPool::RunUntilCompleteHlpr start thread
[0x94],index=0
CThreadPool::RunUntilCompleteHlpr start thread
[0x98],index=1
Script file copied to '\\GHPDB1
\ADMIN$\GHPDB1_MSSQLSERVER.iss' successfully.

Installing remote service (GHPDB1)...

An error occured in the service create (GHPDB1): 5...

CThreadPool::RunUntilCompleteHlpr WaitForMultipleObjects
returned: 0
CThreadPool::RunUntilCompleteHlpr signaled thread [0x98]
Thread [0x98] exit code: [0x5]
CProcess::RunUntilComplete [0x94] exit code: 3010
Remote process exit code was '3010' (GHPDB2).

CThreadPool::RunUntilCompleteHlpr WaitForMultipleObjects
returned: 5
CThreadPool::RunUntilCompleteHlpr signaled thread [0x94]
Thread [0x94] exit code: [0x5]
CThreadPool::RunUntilComplete returned 5
CThreadPool::RunUntilComplete execution level=1, need
execution: 0
One or more errors occurred while running the
remote/unattended setups.

Disconnecting from remote machine (GHPDB2)...

Service removed successfully.

Remote files could not be removed.

#### SQL Server Remote Setup - Stop Time 09/19/03 01:02:00
####

Disconnecting from remote machine (GHPDB1)...

Service removed successfully.

Remote files removed successfully.

#### SQL Server Remote Setup - Stop Time 09/19/03 01:02:00
####

I cannot find a log on the remote node at all.