Visio Viewer 2003 shows blank pages in Internet Explorer 6

Visio Viewer 2003 shows blank pages in Internet Explorer 6

Post by Amedee Van » Thu, 31 May 2007 16:20:17


Hello,

When opening a Visio .vsd file created with Visio 2002 or 2003 using
Explorer -> right mouse button -> open with -> Internet Explorer, I
get a blank page.

Already tried the following but nothing helped:
* Uninstall/Reinstall of Visio 2003 Viewer
* Repair of Visio 2003 Viewer
* http://www.yqcomputer.com/
* Install of Visio 2007 Viewer

Visio Professional 2003 is also installed on my pc, but I don't know
which was installed first: Visio or the Viewer.
But the problem appears also on pcs without Visio Pro. Currently we
have no other option than to advise our users to request that Visio
Pro is installed, but we would like to avoid that because of licensing
costs (and because most people don't need to edit Visio files anyway).

Interestingly, this problem does not occur on every pc, and the
problem started to appear only a few weeks ago. All pc configurations
should be the same, and I have no information about any differences
between pcs or anything that has changed since a few weeks (software
installation is for another department, I only do Office support).

TIA,
 
 
 

Visio Viewer 2003 shows blank pages in Internet Explorer 6

Post by Amedee Van » Thu, 31 May 2007 16:50:49


*snip*

Could this be related?
http://www.yqcomputer.com/ +viewer&rnum=17&hl=nl#a16524b5c6389d74

"This is Damodar from Microsoft Customer Support Services.
I tried to contact you but was unable to touch base. I worked further
on
this issue and was able to reproduce the issue as mentioned by you.
I could not find any resolution or work around for this issue at this
point
in time. Also I would like to let you know that the issue is related
entirely
with the Visio Viewer and its interaction with Windows XP SP2.
At this point in time I can only escalate this issue but won't be able
to
give you an assurance on the resolution because this is related to
Visio
Viewer and ideally we do not provide hot fixes for Visio Viewer, for
that
matter any viewers unless there is a major security breach."

My collegue who has a WinXPsp1 can open Visio files with IE, and I
can't - I have WinXPsp2.
I still have to veryfy other sp1/sp2 installations.

 
 
 

Visio Viewer 2003 shows blank pages in Internet Explorer 6

Post by Amedee Van » Thu, 07 Jun 2007 23:14:20

*bump*
Nobody?

I found that opening a Visio file embedded as an ActiveX in an html
file works.
For example take the Visio file that the viewer installs as C:\Program
Files\Microsoft Office\Visio Viewer\1033\SAMP_HTM.HTM

----------CUT HERE----------
<html>

<head>
<title>Microsoft Visio Viewer Sample Page</title>
</head>

<body>

<p>
<!--
If you want the Visio Viewer to autoinstall when a user navigates to
your web page,
you will want to substitute the following line for the equivalent
line below:

<OBJECT classid="CLSID:279D6C9A-652E-4833-BEFC-312CA8887857"
codebase=" http://www.yqcomputer.com/
vviewer/2003/w2kxp/en-us/vviewer.exe"
id="viewer1" width="100%" height="100%">
-->

<object classid="clsid:279D6C9A-652E-4833-BEFC-312CA8887857"
id="Viewer1" width="100%" height="100%">
<param name="BackColor" value="16777200">
<param name="AlertsEnabled" value="1">
<param name="ContextMenuEnabled" value="1">
<param name="GridVisible" value="0">
<param name="HighQualityRender" value="1">
<param name="PageColor" value="16777215">
<param name="PageVisible" value="1">
<param name="PropertyDialogEnabled" value="1">
<param name="ScrollbarsVisible" value="1">
<param name="SizeGripVisible" value="1">
<param name="ToolbarVisible" value="1">
<param name="SRC" value="SAMP_VDX.VDX">
<param name="CurrentPageIndex" value="0">
<param name="Zoom" value="-1">
</object>
</p>

</body>

</html>
----------CUT HERE----------

Opening SAMP_HTM.HTM with IE -> works.
Opening SAMP_VDX.VDX with IE -> does not work, blank page.

I could use this workaround for the very few files that are referenced
from our intranet, but most Visio files wind up in all kinds of
strange and *** file shares, and our users should just have to
doubleclick them and have Internet Explorer open them using the Visio
Viewer.

The problem does not occur on all pcs, but we cannot find a difference
between a good and a bad box. Not even with filemon and regmon. (from
sysinternals) Service Packs, updates,... nothing seems to be a
determinating factor.

Dear lazyweb, do you have any suggestions?
 
 
 

Visio Viewer 2003 shows blank pages in Internet Explorer 6

Post by UmF5S2FyZW » Wed, 15 Aug 2007 15:58:00

We also have the same issue with all the same symptoms.
An additional comment on this issue is that the VSD will open in IE6 if it
is on the local C: drive and not on a network or redirected folder. Checked
to see if there was an issue with long file names by creating a long path and
file name on the C: drive. The file still opens in IE6 as long as it is on
the local drive.
I have checked out the following links with no luck because they don't apply:
http://www.yqcomputer.com/
http://www.yqcomputer.com/
http://www.yqcomputer.com/