store.exe and inetinfo.exe memory leaks?

store.exe and inetinfo.exe memory leaks?

Post by Chris McKi » Thu, 13 Nov 2003 09:07:34


Hey All,

I've got a huge problem with store.exe and inetinfo.exe tying up massive
amounts of memory and not releasing it until I reboot the server. Furhter
as this ties up physical memory, my pagefile grows astronomically. I've
read a number of articles that mention antivirus being a cause of this or
that one of the recent hotfixes is an issue or even backup software. None
have a definitive answer and I need to get this fixed.

Here is what I have

Dual Processor Dell 2GHZ
4 Disk RAID 5 for the exchange installation
2 Disk Mirror for the System Partition
512MB Memory (which will be upgraded)
Windows2000 SP4 with all the latest hotfixes
Exchange 2000 SP3 with the latest post SP3 SRP

Running GFI Mail Essentials 9.0 for Exchange (build 20031003)
Running Exchange Remote Agent for Veritas Backup Exec 9.0
NO Antivirus software installed

I'm not sure if this is due to the fact that I'm running OWA on the same box
is causing the inetinfo.exe problem? Regardless, it takes up quite a bit of
resources as well and needs to be reigned in. I think this is bleeding over
into a problem that all my outlook clients are having getting a "Requesting
Exchange Server info" message trying to get new email from the server.

Cheers,
Topher
 
 
 

store.exe and inetinfo.exe memory leaks?

Post by Neil Hobso » Thu, 13 Nov 2003 17:19:30

How much memory are store and inetinfo taking up? How much available memory
is on the system?

For Exchange news, links and tips, check:
http://www.yqcomputer.com/



box
of
over
"Requesting

 
 
 

store.exe and inetinfo.exe memory leaks?

Post by Ben Winzen » Fri, 14 Nov 2003 00:02:27

How many users are you supporting? The "requesting data" error more often
than not indicates that the server can't keep up with the RPC requests that
are coming in. Also, more often than not, it is due to a lack of physical
memory. Check this link and go through the steps that will show you how to
figure out if the problem is with memory (or lack of), or something else,
such as disk subsystem, or network.

Also, FYI, but Exchange is designed to take up as much memory as is
available and is needed. If I open Task manager on my server, store.exe is
using 1gb of memory and inetinfo is likely using a chunk as well, though I
couldn't tell you the number off-hand. If another process on the system
requires memory, Exchange is supposed to give it back to the system, so that
it can be allocated to the other process.

--
Ben Winzenz
Network Engineer
Gardner & White

Exchange FAQ's: http://www.yqcomputer.com/
Exchange 2000 FAQ's: http://www.yqcomputer.com/




box
of
over
"Requesting
 
 
 

store.exe and inetinfo.exe memory leaks?

Post by Chris McKi » Fri, 14 Nov 2003 01:02:24

with the 512 of memory I have store.exe takes between 280 and 300MB and
Inetinfo about 175MB (this is when mail stops routing etc). My page file
swells to over a 1GB. Available physical memory will drop below 10MB.




memory


Furhter
or
None
bit
 
 
 

store.exe and inetinfo.exe memory leaks?

Post by Chris McKi » Fri, 14 Nov 2003 01:03:40

Ben, supporting about 35 users, I'll check the link and let you know if it
helps. Thanks!



that
to
is
that


Furhter
or
None
bit
 
 
 

store.exe and inetinfo.exe memory leaks?

Post by Ben Winzen » Fri, 14 Nov 2003 01:36:12

ops. I think I forgot to post the link....
Here it is:
http://www.microsoft.com/technet/treeview/default.asp?url=/technet/prodtechnol/exchange/exchange2000/support/TROUPERF.asp

--
Ben Winzenz
Network Engineer
Gardner & White

Exchange FAQ's: http://www.swinc.com/resource/exch_faq.htm
Exchange 2000 FAQ's: http://www.swinc.com/resource/e2kfaq.htm


"Chris McKinlay" < XXXX@XXXXX.COM > wrote in message
news:% XXXX@XXXXX.COM ...
often
physical
else,
I
massive
I've
same
bleeding


 
 
 

store.exe and inetinfo.exe memory leaks?

Post by Scallic » Fri, 14 Nov 2003 11:44:17

Chris,

I recently had a similar problem. The problem was that there were three 20MB
emails stuck in the queue. I solved it by clearing the queue. Go go
C:\Program Files\Exchsrvr\Mailroot\vsi 1\Queue and see if anything is
clogged in there. If so, stop SMTP service, delete all the emails in there
and restart the SMTP service. Good luck.

-Scallica-



box
of
over
"Requesting
 
 
 

store.exe and inetinfo.exe memory leaks?

Post by kplouff » Wed, 10 Dec 2003 00:38:05

Hi,

I am also experiencing this problem on my exchange 2003 server. It
started right after I installed GFI Mail Essentials 9.0 on the server.
I am working with GFI tech support, but with no resolution yet. I
discovered that the "Private Bytes" for Inetinfo.exe is where all the
extra memory is being hogged. The Store.exe is using minimal (400MB)
of RAM, Inetinfo.exe (300), but the committed bytes on the server is
up to 1.75GB. The difference is in "Private Bytes" for inetinfo. I
also noticed that the memory usage jumps over the weekend. Does anyone
have any idea of what this might be?

Also (it might be related), we have been getting a few totally blank
emails coming in (no subject, no from:, no to:, no body).

Thanks for any help you can provide!
Kevin
 
 
 

store.exe and inetinfo.exe memory leaks?

Post by kplouff » Wed, 31 Dec 2003 03:17:57

FI has released an update which addresses this memory leak problem.
It has to do with the "Move messages to user folder" feature. Here is
the link to the new build of MailEssentials, which also has an
explation of the memory leak.

http://kbase.gfi.com/showarticle.asp?id=KBID001924


XXXX@XXXXX.COM (Kevin Plouffe) wrote in message news:< XXXX@XXXXX.COM >...